SyntaxHighlighter

Tuesday, January 12, 2010

RubyGem version error: rack(1.0.0 not ~> 1.0.1)

If you see this error - it may be due to the fact you installed Rails 2.3.5 a while ago and you do not have 1.0.1. Even after installing the latest rack gem, this error may persist.

Here are many people with the same issue

http://weblog.rubyonrails.org/2009/11/30/ruby-on-rails-2-3-5-released

I got around this by uninstalling rack and rails 2.3.5. When I reinstalled rails, it included the rack dependency.

1 comment:

  1. Anonymous2:17 PM

    Thanks for this post - this was the easiest solution I found online by far :-)

    ReplyDelete